Software Renewal/Upgrade

Some older Troopmaster programs have become outdated and are no longer available for renewal. These include:


TroopMaster/PackMaster 2016

TroopMaster/PackMaster DotNet

TroopMaster/PackMaster Web 1.0


If you are using any of these packages, you should updgrade to our new 2018 or Web 2.0 versions to manage your unit data. The latest version are fully up to date to match the new handbooks and are also compatible with the new Internet Advancement 2.0 system for submission of your unit advancement reports to your council. Please click below to order the latest version for your unit:


Click here to order the latest version of TroopMaster

Click here to order the latest version of PackMaster



If you have any questions, please give us a call at (434) 589-6788 or via email at: techsupport@troopmaster.com